Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday I began setting up a server with Windows Small Business Server 2008. All I am configuring it for right now is to be a domain controller and Exchange server.

I completed the initial setup of SBS then started looking through different connection options (allowing VPN versus using a TS Gateway). After I rebooted one time, I started having three not-obviously-related issues:

First, I could no longer remote desktop into the computer. I ran TCPView and saw that it was no longer listening on port 3389. I checked everything in Terminal Service Configuration but everything shows the computer ought to be allowing connections.

Also, when I tried to use anything that required user account control elevation, the UAC dialog never popped up and the program that was waiting just froze. If I try to run "regedit" from the Run box, for example, it never appears. When I run in safe mode which does not run with UAC, I was able to access everything. I didn't want to deal with it, so I turned off UAC and rebooted.

Finally, in the Windows SBS Console, there are status indicators for Security, Updates, Backup, and Other Alerts. The first three get stuck saying "Querying". Looking in the computer alerts, I have events showing the following services stopped:

  1. Background Intelligent Transfer Service
  2. KtmRm for Distributed Transaction Coordinator
  3. Distributed Transaction Coordinator
  4. Microsoft Exchange Information Store
  5. Microsoft Exchange System Attendant
  6. Microsoft Exchange Transport
  7. Windows Remote Management
  8. Update Services
  9. Windows Update

I figured I must have configured something wrong accidentally and I couldn't find anything using Google explaining what might be the case, so I just decided to format the hard drive and reinstall SBS from scratch. I did this and everything was working last night, but I just turned the machine back on and it is doing the same thing again!

On my second install, I did not configure anything except the following (all from SBS Console):

  1. Connect to the Internet (set IP and router address)
  2. Turn off customer feedback.
  3. Set up internet address.
  4. Decline to use a Smart Host for email.
  5. Added one standard user account.

Since this happened again and I was very careful the second time not to configure anything outside of the SBS Console, I feel like there's something else going on.

Right now the machine is on an isolated network that does have internet access. My desktop is the only other machine plugged into this network.

Any and all help is appreciated (before I tear my hair out!)

share|improve this question
up vote 0 down vote accepted

I'm fairly confident the problem was one of or a combination of:

  1. Setting a Secondary DNS server from my ISP rather than leaving the SBS server as its own sole DNS server.
  2. Disabling IPv6 because I believed I didn't need it.

I've since reinstalled and avoided disabling IPv6 or setting a secondary DNS server (instead adding our ISP's DNS servers as forwarders in Admininstrative Tools → DNS Server). I've yet to see any issues, although that's not to say they won't return.

However, if anybody can explain in an answer how exactly one or both of these would have caused my issues I will gladly give them the accepted answer.

share|improve this answer
Disabling IPv6 on a SBS 2008 machine is, generally speaking, a Bad Thing:… – Wesley Sep 17 '09 at 1:16

I had the same problem... The solution is rather simple! If there is any problem with the network connection, it will simply not start with those services! Why does this happen, I dont know, but in my case, I was trying to start the server without the network cable pluged...


share|improve this answer

One thing to consider if I understand your question correctly is that I think Exchange is meant to only run on the box itself, and the domain controller should be separated too...I think MS will hesitate to support it if something goes wrong since it's not approved to be used that way.

I'm sorry I don't have a solution to your question, but this could be an issue down the road for you...some thoughts, though...

Is "allow remote help" turned on? I think this article could help with setting it up. Also, does UAC only work if at the console? I'm not sure.

share|improve this answer
Small Business Server is a bundled OS that Microsoft sells which behaves as a domain controller and Exchange server (among other things). It is designed as an all-in-one server solution for small businesses. UAC normally works either at the console or through RDP, but right now it's not working at the console since I can't RDP into it. – Stephen Jennings Sep 14 '09 at 14:16
Oh, sorry about that then. We kept getting warned about dire consequences for doing anything other than having exchange function alone on a system. Did the link for the remote access help at all? – Bart Silverstrim Sep 14 '09 at 14:26
Most of that page is for setting up a VPN. I didn't change any VPN settings this time (I enabled it on the first install, but not the second one), and remote desktop is turned on. – Stephen Jennings Sep 14 '09 at 15:32 about this one? – Bart Silverstrim Sep 14 '09 at 15:35
It looks like the registry key is already set the way they suggest. – Stephen Jennings Sep 15 '09 at 4:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.