Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Ubuntu 9 server with samba 3.3 installed. This server has two network interfaces, one to a "public network" which I do not have any control over and another to a private LAN.

On the private LAN, samba is the Domain Controller and nmbd is the WINS server on that network.

On the "public network", I have configured a second instance of nmbd to run as a WINS client.

The setup seems to work fine for Windows XP (on the domain or otherwise) as well as other Ubuntu machines.

Finally, my question: Mac computers seem unable to connect to the samba server. As far as I can tell, it is as if samba is invisible to the MAC computer. Could my configuration of nmbd be causing this problem? Or is this simple a Mac oddity and is there anything I can do about it?

New updates/info: We tried to connect through the Finder -> Connect to Server, we entered smb://servername where servername is the netbios and DNS name. (There is also a DNS entry for the same name on the network) We also tried connecting by IP address

Also, I just realized that there is at least one Mac which can connect. (Leopard 10.5.8) I will try to get the Mac OS versions of the computers which couldn't connect as soon as I can.

The Mac which could not connect was running Mac OS X 10.4.11. Was there a change to samba on Mac OS between 10.4 and 10.5?

share|improve this question
add comment

3 Answers 3

How do you try to connect to the server? With netbios name? IP adress? Is your WINS server configured in the MacOS network preferences?

share|improve this answer
    
I've added the information in the original question. –  tan-ce Sep 15 '09 at 21:18
add comment

As SvenW has alreayd outlined - we really do need a little more info to really help.

What I do know is that on OS X WINS will not be set up by default. You need to go to the Network preference pane in System Preferences, pick the network interface you're using, then click "Advanced" and enter in the correct detail in the WINS tab.

If you connect via IP address it should just work anyway.

share|improve this answer
    
I've edited the information into the question. As stated above, there is also a DNS entry for the same name to the same machine. Also we tried connecting by IP address. But seeing as it isn't all Macs which can't connect, I'm beginning to suspect a problem on the Mac's end... I'm gonna try to ask my friends who have Macs to try to connect and see if the majority are able or unable to connect. –  tan-ce Sep 15 '09 at 21:21
add comment

Only macs using snow leopard have the problem. The snow leopard samba implementation encrypts everything which causes a problem with samba servers not using/expecting encryption. On leopard encryption can be turned off.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.