Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a set of production and non-production Windows 2003 servers. I want to initiate a file copy between one of the production machine to a samba share on a Linux machine. I can access and mount the share on non-production machines but I can't do the same on productions machines. When I try to map the share as network drive, it comes up with a logon dialog but fails to connect to the share after supplying the proper credentials. The error message is,

System error 64 has occurred.

The specified network name is no longer available.

This doesn't happen on non-production machines. Also this only happens to samba share and not to windows shares. So this obviously looks like some network/security settings either on the windows or samba server that affect the share access. What are all the settings that I should I check and how should I proceed from here to fix the issue? Thanks in advance

share|improve this question
    
What version of Windows do you have running in each environment? This could be NTLM authentication-related. –  user3914 Sep 14 '09 at 17:52

1 Answer 1

up vote 1 down vote accepted

I am curious what kind of firewall setup you have, and if it differs on your production and non-production systems. According to here, these are the ports you need to allow:

netbios-ns 137/udp # NetBIOS Name Service
netbios-dgm 138/udp # NetBIOS Datagram Service
netbios-ssn 139/tcp # NetBIOS Session Service
microsoft-ds 445/tcp # Microsoft Directory Service

If you have some of these set up, but not all of them, it could explain why you get the password authentication box but then it can no longer communicate with your samba system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.