Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've installed freeSSHd on a Windows Server 2008 box (following the instructions in How to install an SSH Server in Windows Server 2008), including:

  • created a user named "dspitzer" with NTLM authorization
  • opened an exception for port 22 in the Windows Firewall

But when I try to connect (from a Mac OS X 10.5.8 command-line), I get permission denied after entering the password:

$ ssh 12.34.56.78
dspitzer@12.34.56.78's password: 
Permission denied, please try again.
dspitzer@12.34.56.78's password: 
Permission denied, please try again.
dspitzer@12.34.56.78's password: 
Received disconnect from 12.34.56.78: 2: Too many attempts.

I've also tried:

$ ssh dspitzer@12.34.56.78
dspitzer@12.34.56.78's password: 
Permission denied, please try again.
dspitzer@12.34.56.78's password: 
Permission denied, please try again.
dspitzer@12.34.56.78's password: 
Received disconnect from 12.34.56.78: 2: Too many attempts.

I've also tried changing the authorization to "Password stored as SHA1 hash" and entering a simple password, but I get the same problem. And I've tried a different user name ("Administrator") with no luck.

I've confirmed that I am connecting to the server I'm configuring—if I stop freeSSHd and try to connect I get:

$ ssh 12.34.56.78
ssh: connect to host 12.34.56.78 port 22: Operation timed out

I get the exact same results from a Linux command-line.

Any advice or troubleshooting tips?

Update: I tried disabling the firewall (in response to geeklin's comment) and it made no difference.

Update #2: I no longer have this machine (I've changed employers), so I have no way of verifying the answers. I guess all I can do is make this question "community wiki".

share|improve this question
    
Have you tried disabling the firewall altogether, just as a test? –  geeklin Sep 14 '09 at 21:10
    
do you have a valid Windows user to match the one you set up in FreeSSHd? –  Jeff Atwood Jul 25 '10 at 15:50
4  
freeSSHd might be cool but its out of development for 2+ years now and WinSSHD was last updated Oct-2011 ... –  djangofan Nov 15 '11 at 22:31

6 Answers 6

Well, I realize the SSH command line client should work fine, but as a troubleshooting tip I would try to connect to the SSH server using a windows Putty client and see what happens. Also, run "netstat -anb -p tcp" at the dos command line to see if the port is actually listening on 22.

share|improve this answer

I was having similar problems with freeSSHd 1.2.6.22: access denied when connecting (putty or unixutils ssh).

Following an advice found on the Internet, I tried reinstalling freeSSHd, as crazy as it may seem. To my surprise, I was able to set up both an NT user account and an SHA1 one.

However, the problem seem to return occasionaly. Restarting freeSSHd might help.

share|improve this answer

Try the following:

ssh -v 12.34.56.78

This will tell SSH to output verbose messages about what its doing. It probably wont reveal anything, but its worth a shot.

Also another reason why its not letting you in is because the shell hasn't been properly set or the permissions forbid freeSSHd from running it. Is freeSSHd running as an unprivileged user?

share|improve this answer

I installed freeSSHd just last night and ran into this same issue. The problem seems to be that I installed freeSSHd as a Windows service. When The windows service is running, it doesn't pick up the user accounts. Did you also install freeSSHd as a service?

Now, if I log into the server, stop the freeSSHd service, and start up freeSSHd from the desktop icon or start menu, I get a little icon in the tray. Double clicking it brings up a properties window, and I can start the server from there. If I run the server from here, I am able to log in with those user accounts.

It's good to know I can SSH in at all, but it defeats the purpose of having a Windows service if I can't use it. Has anyone else come across this issue and been able to fix it?

I have tried having the server running locally, and then also starting the service. I can log in, but then when I stop the local server, I can't connect anymore. It's as if the service isn't running.

I've tried running the service and starting the server locally at the same time, but I can't start the server locally after the service is running.

I've tried modifying the service so that it logs on as my administrator account. That didn't seem to help.

This is driving me mad! Has anyone been able to configure freeSSHd to work as a service with accounts? Has anyone else got experience with other SSH servers for Windows Server 2008?

share|improve this answer
    
not really an answer but might have some troubleshooting ideas for others. –  Jeff Atwood Jul 25 '10 at 15:52

I was having issues with this too and this is what worked for me:

  1. Turn off the FreeFTP service & make sure any FreeFTP icons are unloaded from the tray
  2. Open a fresh FreeFTP icon (the one that loads in the tray)
  3. Change your settings and click the "Unload" option to close it when done (this seems to save the configuration for the service)
  4. Restart the service (seems to load the latest configuration that you just unloaded from the tray)

It seems a little backwards but after that, I was able to connect using the SHA1 option and didn't get the "Access Denied" message. Maybe it will work for someone else as well. Good luck!

share|improve this answer
    
Restarting the Windows service fixed the "Access Denied" message for me. Thanks for the suggestion! –  Gili Feb 2 '11 at 21:15
    
This was the solution for me. Even running freeSSHd without the service installed I was getting the "Access Denied" message. Seems you have to completely "unload" then reload freeSSHd for any setting changes to take place. > I was having issues with this too and this is what worked for me: > 1.Turn off the FreeFTP service & make sure any FreeFTP icons are unloaded from the tray > 2.Open a fresh FreeFTP icon (the one that loads in the tray) > 3.Change your settings and click the "Unload" option to close it when done (this seems to save the configuration for the service) > 4.Restart the service –  user147704 Nov 30 '12 at 3:42

Click the "Unload" context menu and reopen works!

share|improve this answer
    
BIG Thank you!!! –  Dmitriy Naumov Aug 7 '11 at 1:20
2  
Unfortunately it seems the application server of this program is dumb and needs to be fully restarted. Any changes you make to any settings won't take effect until the program is restarted. FRUSTRATING!! –  MikeMurko Dec 27 '11 at 0:49
    
Worked for me too, thanks –  Petah Jun 13 '12 at 23:26
    
Another point I found that proved to be very important is running the system tray version as administrator (even if you're already in the administrator group). I found that the settings weren't picked up by the service when using the system tray executable under my own user to configure everything. –  Derek Greer Dec 19 at 20:20

protected by Chris S Dec 4 '12 at 18:00

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.