Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

i m trying to configure samba server in rhel5.when i try to share some dir of my linux system on which i m configuring samba and change workgroup of one the windows clients then that windows client shows samba server icon bt on clicking that icon when i enter username and password for the registered user(means the username and password for that windows client) it does not connect to the shared dir.i changed my samba.conf file parameters several times bt even then the prob is still unsolved.what could be the other reasons for all such happenings or what shud i do with my samba.conf file.kindly help me out.

share|improve this question

migrated from stackoverflow.com Sep 14 '09 at 20:18

This question came from our site for professional and enthusiast programmers.

    
Are you trying to connect using Acitve Directory credentials? –  geeklin Sep 14 '09 at 20:21
    
Did you type this on your circa 1999 Nokia phone?? More people would help if your question wasn't so difficult to parse. –  jdizzle Mar 10 '10 at 4:25

3 Answers 3

If it's popping up with an auth request, try

smbpasswd -a <username>

set the password to the same as on the windows side

share|improve this answer

Have you run testparm on your smb.conf to test for internal consistency?

Next, what sort of authentication are you using?

Try stripping out all the comments and whitespace and posting your smb.conf file.

share|improve this answer

There's several configuration options that effect this.

Map To Guest = [Never, Bad Password, Bad User, Bad Uid]

The way to simulate most end-user windows machine sharing behavior is to use "Bad Password". This means that whenever you fail to authenticate, it just uses the guest account. Best for read-only access.

Now, under the particular share you can use the public option.

[my_share]
path = /path/to/dir
public = yes
writable = no

The combination of the Map to Guest = Bad Password configuration option, and the public = yes configuration option should allow anybody access your share with read-only privileges. Be careful because smb will actually setuid() to the user that was authenticated (in this case, nobody), so all the files have to have the correct unix permissions for nobody to read them.

If you actually want to authenticate users, you'll have to use the smbpasswd tool. Samba maintains its own shadow-hash file for users. If you actually want to use user authentication then you'll have to use smbpasswd -a <username>, like greeblesnort suggests. The username is a username of a linux user. You can maintain different passwords for Samba authentication and for the rest of the system. Again, you'll have to doublecheck the linux file permissions to make sure that the user you want to grant access to can read/write in the directories you're sharing.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.