Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a problem with one database on my SQL Server 2005 production server.

A number of databases are already set up for mirroring, however when I right click and go to properties in SSMS, on one particular database there is no "Mirroring" property page available.

I have done the normal tasks, such as setting Full Recovery model, running a full backup of the database and backing up the logs.

I can't see that this is a server specific issue as other databases are happily mirroring.

I've looked around and I can't see that I'm missing a setting, any help would be appreciated.

Thanks.

EDIT: This is nothing to do with the Mirror Database yet, I can't get as far as specifying the Mirror Database, I cannot see the "Mirroring" page on the principal.

EDIT: I have managed to set up mirroring using t-sql commands. However I am still unable to see the "Mirroring Page".

UPDATE: This applies to the Transaction Log Shipping option as well. I can successfully set it up in SQL but not through SSMS.

share|improve this question
    
How many databases are you mirroring in one instance? –  SuperCoolMoss Sep 16 '09 at 18:49
    
I was mirroring 7 databases, I'm now down to 1. The problem is not specific to mirroring, I can't get access to the the Transaction Log Shipping page either. –  MrEdmundo Sep 16 '09 at 21:02
add comment

4 Answers

In installed SQL Server 2008 as a bare bones installation, just the "Database Engine" and "Management Tools - Basic" components and had the same problem.

Adding the "Management Tools - Complete" component fixed the problem for me.

No thanks to MS for the non-existent documentation on this point. :-|

share|improve this answer
add comment

I have been caught out by SSMS respecting database permissions and not showing options for some users previously. Are you connected with server admin permissions or as a less privileged user?

Just a thought ...
Jonathan

share|improve this answer
    
It's a nice thought, unfortunately no good. Tried logging in as sa and no luck. Thanks. –  MrEdmundo Sep 17 '09 at 16:29
add comment

I had the same exact symptoms, although I didn't have any databases setup with mirroring. I ultimately couldn't find documentation to support my solution, but it worked for me.

I had SSMS - Basic installed. After I uninstalled it and installed SSMS - Complete instead, Mirroring and Transaction Log Shipping are now visible entries in the Properties page.

Microsoft only says the following about ADV_SSMS, which seems to be inadequate given what I learned:

Installs SQL Server Management Tools – Complete. This includes the following components in addition to the components in the Basic version:

  • SQL Server Management Studio support for Reporting Services, Analysis Services, and Integration Services

  • SQL Server Profiler

  • Database Engine Tuning Advisor

share|improve this answer
add comment
up vote 0 down vote accepted

I ended up having to have a Microsoft Support call for the problem I was facing. Anyway after sometime and a number of support sessions they worked out that the database with the problem had an ID of 4 in sys.databases. IDs 1-4 are usually reserved for the system databases and if a database has any of these ids the T-log or Mirroring properties are not displayed. So somehow are database got the ID 3 and now I better get on and detach and reattach some databases to reassign IDs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.