Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I stop the SMTP Service on Windows 2003 (not exchange) from sending "Delivery Status Notification (Failure)" messages?

I'm trying to prevent a trick that spammers use of sending a message to a bogus user on my server's domain, with the sender's address as the Spam victim's address.

The result is that the SMTP Service will send back to the listed "sender" a "Delivery Status Notification (Failure)" message, which contains the spam message.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I found a discussion about this topic on Coding Horror. I went with the scripted solution by Alex Feinman. The things I ran into is that if you have more than one domain, you can only have one catch all for all domains. Also, this doesn't cleanup the catch all folder, so you need another script to do that, or do it manually.

share|improve this answer

Configure your server to not accept mails for noon-existant recipient addresses. I don't have an Exchange right now to test that, but probably something like:

From Exchange System Manager, Global Settings, Internet Message Format, double click on your right. Advanced tab. Uncheck Allow non-delivery reports.

Also see here.

share|improve this answer
    
I'm not using Exchange, I'm using the free SMTP Service that comes with Windows 2003. –  Josh Sep 15 '09 at 19:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.