Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a server that we're currently building with Windows Server 2008 and SQL Server 2008 I'm trying to enable remote connections to SQL, and had followed all instructions of allowing TCP connections in the SQL Configuration Manager, starting SQL Browser etc....

Nothing worked. I then turned OFF windows firewall, and it started working.

What setting in Windows Firewall would be preventing external connections? I added an "allow" rule to port 1433 but this didn't work....

It's not ideal that i have Windows Firewall turned off the whole time, surely?

share|improve this question
up vote 4 down vote accepted

Are there more than one instance on the server? Did you only open the port? Try adding this as well..

  1. On the Exceptions tab of the Windows Firewall item in Control Panel, click Add a program.
  2. Browse to the location of the instance of SQL Server that you want to allow through the firewall, for example C:\Program Files\Microsoft SQL Server\MSSQL10.\MSSQL\Binn, select sqlservr.exe, and then click Open.
  3. Click OK.

Also, check out this MSDN article.

share|improve this answer

The article Dan posted is good - you might need to open port 1434 UDP too for the SQL Browser name resolution service.

share|improve this answer
Bingo. That did it for me. – kdmurray Jun 29 '10 at 19:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.