Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set up an ubuntu server on our corporate network. Added an account for each developer and shared each home directory using samba. This all worked great until I had to add a new user - I can't make the new guy's home directory available via samba.

Normally, I "map network drive" in windows, using \\servername\username and the username and password. This works great for the existing users, but not the new user.

There's nothing in the smb.conf file that lists specific users or directories, and I've barely modified from its default settings. I've restarted the service and server. All the new user's files and directories have the same r/w permissions as everyone else's. The new user is a member of all the same groups as the existing members.

I tried installing the samba client to help diagnose the problem, but that seemed to remove the samba server.

Any ideas how I can diagnose the problem?



share|improve this question
up vote 6 down vote accepted

Did you add new users to Samba users with smbpasswd -a? Also, installing samba client wouldn't remove samba server on any Linux distribution I know. I have samba client on almost all samba installations, especially for diagnosing.

share|improve this answer
All along I'd assumed that Samba used Linux authentication - I'd forgotten that it did its own authentication separately. Thanks. – aidan Sep 16 '09 at 16:40

1 - testparm
2 - smbstatus - if clients are connected
3 - smbclient -L \localhost - to see shares as a client

share|improve this answer
Thanks for the info I tried the first two; they don't tell me anything new, and I can't seem to install a samba client without breaking the server... – aidan Sep 16 '09 at 12:47

Make sure that this entry is in your smbd.conf file:

   comment = Home Directories
   browseable = no
   read only = no
   create mode = 0750

This enables home directories shared via the samba server. Be sure to restart smbd to apply any changes.

You should be able to install the samba client and server (via apt-get) without issues; if you are having problems this could indicate a larger issue with your installation.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.