Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using bind 9.6.1 and about 2 days ago I realized that there is a bug at bind for windows platform.

when server gets "UDP client handler shutting down due to fatal receive error: host unreachable" error. it stays alive but no response for after dns queries. then I need to restart it manually to make it responsive(I put a task for this issue from windows). I cant use microsoft windows dns server because I am using windows 2008 server web edition which does not include that.

so my question is what are the other solutions you use for dns server in windows ?

share|improve this question
is this an authoritative server or recursive only? – Alnitak Oct 6 '09 at 7:21
I dunno real difference. I just bought dedicated server and installed bind9 on it. and configure the domains and its working normally fine. but sometime it stops because of that udp stuff. – özkan pakdil Oct 10 '09 at 12:04

2 Answers 2

I have this EXACT same issue. It seems to be a known bug.

Not that I can find a fix anywhere. Suggestions are appreciated.

share|improve this answer

I found patched 9.5.x version from securityfocus and tried that one too. but it did not solved the udp problem. so at the end I installed vmware and move all dns issues to solid rock debian installation. now there is no complain about dns and timeouts.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.