Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed SQL server 2008 in one of my machines, and i am trying to access the server from a different machine within the same network, and for some reason it cant connect to the server. I allowed remote connections to the server, and added the ports to windows firewall.. is there anything else needs to be done?

thanks

share|improve this question

3 Answers 3

up vote 1 down vote accepted

What are you connecting with and what is the error you're getting? Are you trying to use SQL Server Management Studio?

Make sure the SQL Browser Service is running on the server

Make sure TCP/IP is enabled on your client's SQL Native Client configuration.
1. Open SQL Server Configuration Manager
2. Expand SQL Native Client Configuration
3. Click Client Protocols, make sure TCP/IP is enabled

Also, make sure you've got the right port(s) open on the firewall (I know you said you already have the port open). Default is TCP/1433. This can be changed, though, and if you're using a named instance you will probably need to assign it a static port and add it to the firewall config.

share|improve this answer
    
thanks, let me make sure i have everything in place –  Papillon Sep 18 '09 at 1:54
    
this is what i get now..provider:names pipes provider: error 40-couldnt open a connection to sql server –  Papillon Sep 18 '09 at 3:31
    
Ok, try this then. Go back into SQL Native Client configuration as in steps 1-3 in my answer above and make sure TCP/IP is the first protocol in the list (it's an ordered list). –  squillman Sep 18 '09 at 11:31

Can the other machine see the SQL Server's host machine? Try a ping on name, then IP if the name doesn't respond.

share|improve this answer

Changes to the networking protocols only take place upon the service restarting. Hopefully this isn't a doh moment.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.