Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been having issued with yum for a while, then I disabled all the extra repositories and it started working fine. My problem is I'm trying to get dropbox installed and they don't have an rpm for fedora 8 so I have to go through the whole configure thing. This tells me I need libnautilus-extension.

But that's in the development repo which doesn't work for me. Every time I enable it I get checksum errors. Here's my fedora-development.repo :

[development]
name=Fedora - Development
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/development/$basearc
h/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=rawhide&arch=$basear
ch
enabled=1
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-test file:///etc/pki/rpm-gpg/R
PM-GPG-KEY-fedora

Any ideas?

share|improve this question
add comment

3 Answers

Could try

yum clean all

other wise try explicitly defining the development repo see: https://fedorahosted.org/packagedb/browser/fedora-packagedb-stable/yum.repos.d/fedora-development.repo

share|improve this answer
add comment

I assume that by "getting checksum errors" you mean having yum complain that the checksum of some downloaded files doesn't match. You're probably hitting a mirror with corrupted files. Have you tried commenting out the mirrorlist line and uncommenting the baseurl line?

However, please be aware that you run a good chance of borking your system completely if you pull in packages from rawhide if you're three major versions away (you're 8, rawhide is 11). The dependency tree pulled in will be massive, and even if depedency resolution won't fail complaining about missing dependencies you will have most likely a malfunctioning desktop environment.

share|improve this answer
add comment

As others have pointed out, Fedora 8 is end-of-lifed since I believe September. Fedora 9 is about to reach EOL when Fedora 11 is released. Is there a specific reason you are running such an old version instead of one of the current versions which both provide libnautilus-extension.so.1 in the nautilus-extensions package.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.