Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I administrate several Ubuntu 9.04 servers, and everytime I log in, I get the Landscape utility printout with server stats, etc. I really don't need this and it slows down my logins considerably. Can somebody please tell me how to disable message of the day as well as the landscape-sysin daemon ?

I started tracking my logins using top, and when a user logs in, sshd shoots right up to 100% CPU usage, and I believe that landscape and the message of the day update daemon are the primary culprits. Does anybody else have any ideas as to what could be causing my horrible login times ?

share|improve this question
    
Sorry, I missed responding to the console-kit-daemon part. You mentioned it in the title but didn't refer to it again in the body. See my revised answer. –  Dennis Williamson Sep 18 '09 at 18:59
add comment

5 Answers

I think you don't need consolekit on a server.

I removed it with:

apt-get remove consolekit

(and dbus, too)

share|improve this answer
    
you need dbus though –  verhogen Feb 11 '11 at 1:48
2  
This removes pretty much anything related to X, in Ubuntu 10.04.4 LTS. You probably don't want to do this. –  Brendan Kidwell Mar 31 '12 at 2:05
1  
@BrendanKidwell yeah, but when you have a server with no graphical UI, you don't need it to begin with. –  polemon Jun 12 '12 at 10:59
add comment

You have one or more scripts in /etc/update-motd.d/*. You can remove them or do:

sudo touch /var/lib/update-motd/disabled

See man update-motd:

       This script executes lists of scripts in lexical  order,  concatenating
       and  writing  the  output to /var/lib/motd, which is usually a symbolic
       link to /etc/motd.

       Users and/or packages should add symbolic links to /etc/update-motd.d/,
       /etc/update-motd.d/hourly,    /etc/update-motd.d/daily,    /etc/update-
       motd.d/weekly, /etc/update-motd.d/monthly, prepended with  a  two-digit
       number to define the displayed order, as obeyed by run-parts(8).

       Separate  cron  jobs  will  run  update-motd  every 10 minutes, hourly,
       daily, weekly, and monthly.  Each of execution of update-motd will  run
       the  scripts  in  the corresponding /etc/update-motd.d/ directory.  The
       output of each script will be written and  cached  in  /var/run/update-
       motd/*,  retaining  the number and name of the script executed, to pre‐
       serve the ordering of the output in /etc/motd.  After execution of  the
       current set of scripts, all files in /var/run/update-motd/ will be con‐
       catenated with /etc/motd.tail and written to /etc/motd.

       The update-motd script will not execute if  the  file  /var/lib/update-
       motd/disabled  exists.  One can override this using the --force option.
       To permanently enable/disable update-motd, use:
           $ sudo update-motd --enable
           $ sudo update-motd --disable

If you're using X11/Gnome, I don't think you want to disable console-kit-daemon since it's a part of the login process. If you're not, then I'd just disable X.

share|improve this answer
    
Thank you very much for the response, it does help so +1 for that, but it doesn't completely answer my question : how do I disable console-kit-daemon ? It's killing my performance on logins –  Alex Marshall Sep 18 '09 at 18:32
add comment
up vote 3 down vote accepted

After doing some more Googling around, I found that people were having problems with console-kit-daemon leaving error messages in /var/log/daemon.log regarding the daemon being unable to initialize policykit. I checked my own logs and sure enough I was getting the same thing. I ran

apt-get install -y policykit

and this seems to have fixed the problem. My logins are lightning fast now that console-kit-daemon doesn't have any problems initializing policykit (since it now exists).

share|improve this answer
add comment

I prefer this solution:

touch ~/.hushlogin
share|improve this answer
add comment

I have searched via apt the installed software, and some of them are: landscape-client and landscape-common. I have uninstalled them and the landscape printout don't appeared anymore. Now appears like a Debian install and where are critical updates available, it warns me (I have a cron-job to do an apt-get update everyday al 4 a.m.) Hope will helps

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.