Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Overall, I love the SuperFetch feature in Vista and believe it results in hugely noticeable gains in the launch time and overall "snappiness" of the system. However, sometimes it apparently gets "bored" and attempts to cache huge files in the background that are much too large to fit in available RAM in the first place, such as virtual machine disk files and backup images.

I have searched high and low to no avail for a way to do file exclusions for this reason. Does anybody know if this is possible (or maybe on the wish list for Windows 7)?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

There's no exclusion list. AFAIK, the only way to refine what going on is this registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters

Modify the EnablePrefetcher key to one of the following settings:

  • Disable Caching: 0
  • Cache Applications Only: 1
  • Cache Boot Files Only: 2
  • Cache Everything (default): 3

Experiment with this key to see if caching applications or boot files rather than everything still provides enough of a performance boost without getting bogged down.

share|improve this answer

That's probably not Superfetch, but the volume shadow service backing up your system.

Superfetch learns what programs you use and caches those. (See your Windows/Prefetch directory.) It wouldn't be caching huge files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.