Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

v host running server 2008 r2.

After reboot one of my vm is throwing following error.

'The version does not support this version of file format'

Out of my all vms this was only set to save state when shutdown. I tried deleting state and start still same error. Tried inspect disk as well edit disk both throw same error when try to open this.

What could it be? any way to resolve it?

share|improve this question
    
I had this vhd on NAS when it was throwing this version format error. I moved it to a server and it worked. Again i moved back to san and it worked. So may be just my NAS. –  mamu Sep 22 '09 at 18:07
    
After fixing it with above comment i restarted server and today started getting same thing after restart. So not sure either it's san or hyper-v. So doubt it's san and it handles thousands of files daily without any issue. –  mamu Sep 22 '09 at 18:09
    
well there is a reason that MS doesn't support NAS storage for vhd's. It works but causes issues like this. In windows 8 server they created a whole new cifs protocol for remote based vhd's. –  tony roth Sep 27 '11 at 14:36

1 Answer 1

maybe you have a corrupt VHD? Have you tried to mount the VHD using the Disc Manager in Server Manager?

How to mount the VHD:

  1. Start->Control Panel->Administrative Tools
  2. Double click Server Manager
  3. Expand storage
  4. Right Click Disk Management and select Attach VHD
  5. Click browse and navigate to your VHD
  6. Click Ok
  7. If successfully attached, VHD could be fine. Run a disk check to make sure
  8. When finished, right click the disc in Disk Managment (should be a blue icon and not grey) and select detach VHD
  9. Try restarting your VM and see if the error is fixed.
share|improve this answer
    
Interesting never knew windows can mount vhd –  mamu Sep 22 '09 at 18:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.