Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ran into a problem on a fresh Jaunty server install on a NAS box with 2 SATA cards controlling 6 total disks. The install runs fine, but once it completes and asks for reboot, I get Grub Error 2 on startup. Doesn't seem to matter which disk I install to, or whether I opt for LVM or not. A little research indicates that I need to edit files in /boot/grub, but I'm having trouble mounting /boot when booting from the CD in repair mode.

Any Jaunty-specific tips out there for this? Thanks.

share|improve this question
    
grub is not jaunty-specific, so you can search for your answer anywhere they talk about grub. –  Brent May 10 '09 at 0:04
    
Thanks, to specify I'm looking for a suggestion on what I'm doing wrong with mounting /boot/ in from the install disk repair shell, as that's what I have handy. If there's a live CD that works better I'm certainly willing to give that a go, but it seems like this should work. –  nedm May 10 '09 at 0:49
    
What is the grub error you see? And what is your grub configuration? –  Sander Marechal May 11 '09 at 8:28
add comment

3 Answers

up vote 1 down vote accepted

Figured this out, but it wasn't pretty. I'd install from the server cd, and on reboot it would fail right off the bat, saying only 'grub error 2' (changed eventually to 22). Repairing grub from the install cd didn't fix the problem.

First, it turns out that the order of the sata controllers got switched around on the new install. All the disks were wiped but the hardware wasn't shuffled around, so I'm not sure why this would happen. The problem with this is that only one of the sata cards (the one previously controlling sda-sdc, now sdd-sdf) is bootable. Having figured this out I installed to sdd, but prior installation attempts on the non-bootable disks were visible by grub once it loaded, and deleting them left it loading grub from sdd and looking for a non-existent root on sda-sdc. The solution was to wipe everything again, install to sdd, and run a terminal from the live cd:

sudo grub
grub> find /boot/grub/stage1
 (hd3,0)
grub> root (hd3,0)
grub> setup (hd3)
grub> quit

Makes sense since in /boot/grub/device.map hd3 is mapped to /dev/sdd.

I couldn't find a way in the bios to give the bootable controller any kind of priority for the device ordering, and rearranging the HD boot order in bios didn't seem to matter. Last resort would be to open it up and switch the pci slots of the controller cards around, but since it boots fine now I'm not going to try this -- maybe next upgrade.

share|improve this answer
add comment

Boot in Live-mode, no sweat. I just went through a disk resize and cloning session which got a bit hairy for me, but I was impressed with the power of Ubuntu Live-mode and got to fix the settings in /boot/grub/menu.lst.

share|improve this answer
add comment

the same problem after my home's electricity was broken: grub error 2

enter setup's (DEL) advanced BIOS features and put the bootable hd where it would be: on the top of the list.

if someone knows how something like that could be? i'm curious...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.