Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have linux server in which I run several Tomcats. The current Java I use is 64 bit. All Tomcats use 64 bit java but one. This one Tomcat needs to run with 32 bit Java.

If I don't change anything, this Tomcat starts but the application in it is incompatible with 64 bit Java and I can't use the application. If I set JAVA_HOME, this time it won't start.

Here is what I have done so far:

  1. I edited /etc/environment file and set JAVA_HOME for 64 bit Java
  2. All Tomcats use this path except for the one I modified
  3. I downloaded 32 bit jdk and extracted it. Then I changed bin and jre/bin files with chmod +x command
  4. I edited and added following lines:



  1. I started Tomcat and it failed
    1. This time I tried to install Java to /usr/lib/jvm and modified
    2. I started Tomcat and it failed again. This is the output of catalina.out:

./ 1: eval: /usr/lib/jvm/jdk1.7.0_75/jre/bin/java: not found

If I don't give any path through Tomcat starts (but app doesn't work). If I change the path to 32 bit Java, Tomcat doesn't start. I know I'm giving correct path but Tomcat keeps failing to start.

What am I missing?

share|improve this question
If you do /usr/lib/jvm/jdk1.7.0_75/jre/bin/java -version what happens? Is it successful? could you post the output of ls -l /usr/lib/jvm/jdk1.7.0_75/jre/bin/java? – Mike Feb 26 at 13:56
@Mike I have completely uninstalled all installed Java. I downloaded brand new 32 bit Java. I used the recommended settings and it works now. Don't know what happened though. Thank you – iso_9001_ Feb 26 at 14:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.