Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In the start-up of Ubuntu 9.04 the fsck fails on sda1 with status 8 signal 11.

I believe the problem was caused by the last change made. Ubuntu was running ok, the PC didn't power off on shut-down (it worked like that on WinXp). The line "apm power_off=1" was added in the end of /etc/modules

Now I want to remove that line, but how? The command line in maintenance mode the file system is in read-only mode. I tried to boot ubuntu 4 from the Live CD, but still I get the same start-up fsck fail error.

sda1 is mounted in / the file system and seems ok, i can list files and enter directories...

How can I fix this problem? Can anyone help troubleshooting this problem?

Thanks

share|improve this question
    
Memory (512MB module) that I have on the system is fine. Memtest86+ was running for an hour, 3 Passed 0 Error. Still getting the same singal 11 on ubuntu 9.04 startup. Has anyone have another throubleshooting tip? Maybe the problem is in another hardware component? Or maybe the problem is on the processing of /etc/modules (some software bug) and changing it back may work? Thanks –  jpmartins Sep 20 '09 at 23:08

2 Answers 2

If fsck fails with signal 11 (a segfault) it's not an APM configuration problem -- you've got hardware problems, most likely memory. Get thee to a memtest run immediately.

share|improve this answer
    
Thanks! You seem to be correct, still running memtest86+ In the multiple test memtest86+ executed this error only occurred one time. Failed one time on test 2, addresss 00022bb55bc - 555.3MB, an err-bits 00040000 I have 2 memory modules, one with 512MB and a second one with 256MB. I suspect this problem should be the second module, the 528MB is connected in the first slot, so i supose 555.3MB is on the 256MB module. I will try to remove the second module and try to start ubuntu again. –  jpmartins Sep 20 '09 at 21:09
    
Removed the second module, the symptoms persist... re-running memtest86+ –  jpmartins Sep 20 '09 at 21:31
up vote 0 down vote accepted

Finally fixed it.

The LiveCD was not really booting, changed the bios, started from livecd and changed back the /etc/modules (removed the apm power_off line).

The ubuntu now starts without a problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.