Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Possible Duplicate:
yslow says etags are misconfigured. how to configure etags properly on IIS7 ?

For performance reasons, I'm using expire headers for static files (adding long expiration periods like 50 years or so).

Now I'm trying to get rid of etag headers which are automatically added by IIS7. I've done some searching but it seems harder than what I thought (there doesn't seem to be a straight forward way). I found some workarounds but they all use httpmodules (which I'm keeping as a last resort). I strongly prefer to not get the etag header added in the first place. Did anyone manage to do this?

Thanks

share|improve this question

marked as duplicate by Mark Henderson Jul 9 '11 at 4:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer

There is no setting you can change, which will prevent the tags from being generated/included. The best you can do with settings is make sure the etags which are generated, are empty.

If you do want to remove them altogether, you'll need to rely on modules and/or custom code.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.