Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Updated:

================================================================ I finally found the reason with oprofile. It was because the routing cache of Symfony. We have lots of pages with different urls and symfony caches them in one file (serialized data). So the cache file grows large and it needs more CPU to serialize and unserialize data.

Everything went well after I disabled the routing cache

================================================================

We have three web servers with LVS (Apache 2.11 + PHP 5.26), and we use Symfony 1.0 for our products development.

But recently we have updated our products with Symfony 1.2.7 and we got a critical performance issue.

We use Ganglia to monitor our servers. Before the updates, the average load of web servers is under 1. After the updates, the load increases dramatically with load 80 at top (I can see CPU usage increases much from Ganglia).

I can't find the reasons. Is it because the Symfony framework? (But according to Ganglia, the load shouldn't increase so rapidly).

By the way, in our new products lots of AJAX are used, which means there are at least 5-7 PHP requests to open one page. Is this the reason?

Can anyone help me to find all the possible reasons? Or what else information should I offer to diagnose?

Thanks in advance and looking forward to your reply~

share|improve this question
    
According to Ganglia, only CPU usage increases dramatically –  Mickey Shine Sep 21 '09 at 7:35
    
er... which Apache is that again? 2.0.11 or 2.2.11? I'm assuming the latter. –  Powerlord Sep 21 '09 at 13:21
    
You should make the "Update" an answer to your own question and then accept it so that others know your question is answered. –  Josh Oct 27 '09 at 21:30

1 Answer 1

up vote 0 down vote accepted

I finally found the reason with oprofile. It was because the routing cache of Symfony. We have lots of pages with different urls and symfony caches them in one file (serialized data). So the cache file grows large and it needs more CPU to serialize and unserialize data.

Everything went well after I disabled the routing cache

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.