Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Thanks in advance. I am getting really nervous when I press Tab twice and screen is blinking(goes to opposite color and returns back).

I have tried to change set .Xdefaults file "XTerm*visualBell: False" but couldn’t get rid of this. Have killed VNC process and re-created but still doesn't work! :(

Anyone please help me!!! :)

Thanks in advance.

share|improve this question

6 Answers 6

A quick and easy way I do it:

rmmod pcspkr
share|improve this answer
up vote 2 down vote accepted

I have found the problem: in my home directory there wan another .Xresources file in which it was written

XTerm*visualBell: True

So Xterm was initializing from not .Xdefaults but from .Xresources! Anyway thanks!

share|improve this answer

To disable it on a single xterm: Control middle-click on the xterm, and unselect 'Enable Visual Bell'

The default (according to the manpage) setting for the visual bell is off, so it must be getting turned on somewhere.

Run:

xrdb -query |grep -i ^xterm

And see if the visualBell resource is set.

To disable it for your current session, run:

echo 'xterm*visualBell: false' | xrdb -merge
share|improve this answer

what about

xset b off

greetz

share|improve this answer

Are you using xterm or gnome-terminal?

If the latter, the instructions here show how to turn on the visual bell. I've copied and reversed the instructions so you can turn it off:

  • Be sure gnome-terminal has the bell enabled: In the Gnome Terminal menu: Edit > Profile Preferences > Terminal Bell must be checked. Pressing backspace at a prompt should cause an annoying audible beep.
  • Turn on window flashing: In the Gnome menu: System > Preferences > Sound, click on the Sounds tab, Change the "Visual alert" setting to "Disabled."
  • Enable the audible bell. In the same panel, check the "Play alert sound" check box.

Or you could edit the file ~/.gconf/apps/metacity/general/%gconf.xml and change this line so that it has "true" in it (yes, "true" for "off") as shown:

<entry name="visual_bell" mtime="1253605354" type="bool" value="true"/>

Also, as a workaround, in csh you can:

set nobeep
share|improve this answer

~/.inputrc:

set bell-style none
share|improve this answer
    
doesn't work! BTW I am using csh via VNC. –  Narek Sep 22 '09 at 6:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.