Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've noticed even when I type "hostname" at the CLI the FQDN is displayed, however the only file that seems to be using the short name is /var/log/messages. I'd prefer it to use the FQDN however I can't seem to figure out how to do this.

share|improve this question

2 Answers 2

syslog-ng supports the following option :

use-fqdn(yes);

share|improve this answer

What do you have in your /etc/hostname ??

Try changing it and run

hostname -F /etc/hostname

Additionally you can try adding only a FQHN reference in your /etc/hosts:

YOURIP      your_host.yourdomain.tld
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.