Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm a sysadmin for a school that has a iMac that is setup as the security computer, the security software needs to be running in order to record from the cameras, so the computer needs to be able to automatically log in after a reboot. Right now it does not automatically login. If I goto System Preferences > Accounts > Login Options. The drop down for Automatic Login is greyed out (disabled) and says "Disabled" in the drop down (The lock icon is un-locked, its not that simple). If I go to System Preferences > Security the checkbox "For all accounts to this computer > Disable Automatic Login" is ticked. If I try to un-tick, I get the message "Turning off disable automatic login has no effect. To enable automatic login you must use the Accounts preferences pane." It gives me the option to "Open Accounts", "Cancel", or "OK".

This has put me into a loop, I can't seem to get the automatic login drop down to be enabled so I can select the user to automatically login.

I have repaired permissions on the drive, and that didn't fix it.

Also, in the Login Options pane, there are more options greyed out (disabled):

  • Display login window as: "List of Users" or "Name and password"
  • Show the Restart, Sleep and Shutdown buttons
  • Show password hints

Any thoughts?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Sounds like you're using MCX policy to disable those options. Are you running Open Directory?

share|improve this answer
    
Yes, the system is joined to Open Directory, but in the login options I've disabled the option for remote users to login to the computer. –  ScottN Sep 22 '09 at 19:55
    
That was it, all I needed to point me in the right direction. I opened up work group manager and saw the computer sitting in a group that was applying this restriction. Thanks! –  ScottN Sep 22 '09 at 20:10
add comment

I had the same problem. Under system preferences go to security and privacy. Under the general tab the disable automatic login box is checked by default. To uncheck it you have to click the lock in the lower left hand corner. Hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.