Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a partition on my Hard Drive that I want users to be able to mount, but it shouldn't be automatic, so I've put this in my /etc/fstab:

     /dev/sda5       /media/data    vfat    defaults,user,noauto    0   0

It works great for command line. The partition is mounted only when someone explicitly mounts it.

But whenever a user starts gnome, it automounts the partition, even though fstab says it is not suposed to be mounted automatically.

I know this is almost certainly a gnome setting, but I just couldn't find it in gconf-editor (it looks too much like the Windows register editor for me).

Can anyone help me figure this out?

share|improve this question
    
I did a quick search and found a lot of ways to do this on old versions of Ubuntu, but nothing that works currently. –  Zifre May 10 '09 at 14:34

1 Answer 1

up vote 2 down vote accepted

There's a patch to get gnome to honor the noauto flag:

http://patches.ubuntu.com/by-release/extracted/ubuntu/g/gnome-volume-manager/2.17.0-2ubuntu2/02_honour_automount_enabled_hint.patch

From the surrounding thread, it looks like it's been ignoring it for a couple of versions now:

http://ubuntuforums.org/showthread.php?t=989666

share|improve this answer
1  
For the record: using gnome 2.26.1 in Debian Sid I didn't even need to apply the patch. All I had to do was uncomment the device that starts with "<match key="storage.hotpluggable" bool="false">" in /etc/hal/fdi/policy/preferences.fdi. Thank you very much for your help! –  Flávio Amieiro May 10 '09 at 15:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.