Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a hard disk containing a TrueCrypt volume on /dev/sdc. It is formated with NTFS. I am running Ubuntu 9.4.

To mount the volume I tried this:

 sudo truecrypt -t -k "" --protect-hidden=no /dev/sdc /mnt/data

After providing the correct password I get the following error:

Error: $LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/mapper/truecrypt1': Operation not supported
Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by
          clicking on the 'Safely Remove Hardware' icon in the Windows
          taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for
          your own responsibility. For example type on the command line:

            mount -t ntfs-3g /dev/mapper/truecrypt1 /mnt/data -o force

    Or add the option to the relevant row in the /etc/fstab file:

            /dev/mapper/truecrypt1 /mnt/data ntfs-3g force 0 0

I think, I need to pass the force mount-option somehow to the mount command. But how? The following does not work:

sudo truecrypt -t -k "" --protect-hidden=no --mount-options="-o force" /dev/sdc /mnt/data
Error: Unknown option: -o force
share|improve this question

1 Answer 1

up vote 1 down vote accepted

It is --fs-options=force

sudo truecrypt -t -k "" --protect-hidden=no --fs-options=force /dev/sdc /mnt/data
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.