Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm not sure why, but I'm getting this warning when I start my apache...

su-3.2# /usr/local/apache2/bin/apachectl start
[Wed Sep 23 13:40:42 2009] [warn] (2)No such file or directory: Failed to enable the 'dataready' Accept Filter
su-3.2# grep accf /boot/loader.conf 
accf_data_load="YES"
accf_http_load="YES"
su-3.2# kldstat | grep accf
 3    1 0xffffffff80ce9000 7d0      accf_data.ko
 4    1 0xffffffff80cea000 14d8     accf_http.ko
su-3.2# uname -a
FreeBSD dd.alexus.org 7.2-RELEASE-p1 FreeBSD 7.2-RELEASE-p1 #7: Sat Jun 27 02:42:30 UTC 2009     alexus@dd.alexus.org:/usr/obj/usr/src/sys/GENERIC  amd64
su-3.2#
share|improve this question

3 Answers 3

up vote 3 down vote accepted

Looks like your apache httpd is not looking for the httpready Accept Filter, it is looking for dataready filter. I have no idea why. (Wild guess is that your are using mod_ftp.)

try this:

kldload accf_data.ko

or this in loader.conf:

accf_data_load="YES"
share|improve this answer
    
-bash-3.2# ./bin/httpd -l Compiled in modules: core.c mod_authn_file.c mod_authn_default.c mod_authz_host.c mod_authz_groupfile.c mod_authz_user.c mod_authz_default.c mod_auth_basic.c mod_include.c mod_filter.c mod_log_config.c mod_env.c mod_setenvif.c mod_version.c prefork.c http_core.c mod_mime.c mod_status.c mod_autoindex.c mod_asis.c mod_cgi.c mod_negotiation.c mod_dir.c mod_actions.c mod_userdir.c mod_alias.c mod_so.c -bash-3.2# –  alexus Sep 24 '09 at 14:19
    
I recommend not using the accept filtering in FreeBSD at this time. –  Michael Graff Dec 14 '10 at 15:21

For everyone's information, the reason Apache looks for the dataready filter in addition to the httpready filter is because SSL connections cannot be handled with the httpready filter. The dataready filter almost gives the same level of "avoiding-kernel-mode-shifting" benefits to an HTTPS connection.

share|improve this answer

Do you have accf_data_load="YES" in your loader.conf as well?

share|improve this answer
    
yes, I put that few days ago and I just restarted my box, so it seems like it's working now... –  alexus Sep 24 '09 at 14:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.