Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm writing a powershell v2 script that I'd like to run against a remote server. When I run it, I get the error :

Connecting to remote server failed with the following error message : The WinRM client cannot process the request. Unencrypted traffic is currently disabled in the client configuration. Change the client configurati on and try the request again. For more information, see the about_ Remote_Troubleshooting Help topic.

I looked at the online help for about _ Remote_Troubleshooting, but it didn't point me towards how to enable unecrypted traffic. Below is the script that I'm using that is causing me problems.

Note: I have already run Enable-PSRemoting on the remote machine to allow it to accept incoming requests.
I have tried to use a session option variable, but it doesn't seem to make any difference.

$key = "HKLM:\SOFTWARE\Microsoft\PowerShell\1\ShellIds"
Set-ItemProperty $key ConsolePrompting True

$tvar = "password"
$password = ConvertTo-SecureString -string $tvar -asPlainText –force
$username="domain\username"
$mySessionOption = New-PSSessionOption -NoEncryption 
$credential = New-Object System.Management.Automation.PSCredential($username,$password)

invoke-command -filepath C:\scripts\RemoteScript.ps1  -sessionoption $mySessionOption -authentication digest -credential $credential -computername RemoteServer

How do I enable unencrypted traffic?

share|improve this question

1 Answer 1

New-PSSessionOption has a -NoEncryption option.

$PSSessionOption = New-PSSessionOption -NoEncryption
share|improve this answer
    
Thanks for the response. I added a sessionOption to my call and still get the same error. I've edited my question to include this command. Am I missing something? –  Peter Walke Sep 24 '09 at 18:20
1  
I see you asked your question here also: stackoverflow.com/questions/1469791/… Does the answer there help? –  Dennis Williamson Sep 24 '09 at 19:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.