Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a thttpd server running on an ARM box, and I use it to serve images through a cgi.

What I observe is with each image served, the amount of free memory is lower, and in the psoutput, the VSZ column grow for thttpd.

At some point thttpd gives me an error 500 when asng for the CGI, and the log says "unable to fork"

The amount of memory the vsz is growing is about the size of the image served. Is thttpd doing some kind of caching, but is not able to reclaim memory when forking ? Memory leaking ?

How can I disable this caching behaviour ?

share|improve this question
add comment

1 Answer

There are two directives that allows you to limit the mmap cache of thttpd, they are DESIRED_MAX_MAPPED_FILES and DESIRED_MAX_MAPPED_BYTES.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.