Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Question:
Is there a way to make a browse-able automount directory without mounting the subdirectories?

Background:
I am looking at moving from statically mounted NFS shares, to dynamically mounted NFS shares. The shares are hosted on OS X and OpenSolaris systems, the clients are running Debian and Ubuntu.

I would like the user directories in /home to be dynamically mounted so that the OpenSolaris shares can each be in its own ZFS partition for quota, compression, and duplication tweaking. The OpenSolaris/ZFS best practices guide suggests mounting each directory individually and using an automounter. There is also a danger with a lot of mounted NFS shares running into issues.

My users to need to regularly copy data from another user's home directory, and I think they will panic if the list of user directories is not browse-able.

This illustrates the point, but there must be better solution by now. When I set this up, the directory that hosts the to-be-mounted directory starts empty. It is only after attempting a function (like 'ls folder_name') on a directory I know should exist, that the remote directory is mounted. I understand this is normal for autofs and amd.

If I make symbolic links to the directories so that I have a browse-able tree for my users, each remote share is mounted automatically when the directory that hosts the symbolic links is 'ls'ed. This is largely a waste of mounting as most of those mounts will not be used.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Yes; give automount the "--ghost" flag. Don't know offhand where that's configured in Debian-esque init files.

Aha. Edit /etc/default/autofs to contain the line:

DAEMONOPTIONS=--ghost

I believe that's right.

share|improve this answer
    
Hey, you are totally right. Thank you. If one is running autofs5 on Debian, the option is now called Browse_Mode. So setting: BROWSE_MODE="yes" Took care of it. –  Dru Sep 24 '09 at 18:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.