Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am relatively new to linux and am running centos 5.3 on my VPS. I manage my ftp users via lxadmin - The ftp server that my vps is running is pure-ftpd I believe however recently it has stopped working. Could someone tell me how to restart this service. I have tried running

 /usr/sbin/pure-ftpd restart

But this seems to have no effect. I may be wrong. Any solutions would be greatly appreciated.

share|improve this question

closed as off-topic by HopelessN00b Apr 9 '15 at 19:51

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 1 down vote accepted

You can use:

/etc/init.d/pure-ftpd restart


service pure-ftpd restart
share|improve this answer
When I run this command I get FAILED - Is there a way to show why it's failing? – Malachi Sep 24 '09 at 18:37
check error messages with: tail -f /var/log/messages – HD. Sep 24 '09 at 18:40
I think it's to do with when I ran yum update it updated pure-ftpd - 1.0.20-32.i386 to pure-ftpd-1.0.21-1.el5.rf.i386 which might have messed with the config file or something. – Malachi Sep 24 '09 at 18:47
I see, I think is a weird issue with pure-ftpd running on a CentOS VPS. Take a look at this link… for more information about it. – HD. Sep 24 '09 at 20:13
Thanks you so much! spent ages on this problem and was debating switching from pure-ftpd because of it! cheers for the advice :) – Malachi Sep 24 '09 at 22:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.