Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a script that collates data from a couple databases and generates some Excel spreadsheets (with a *.xls extension) on the web server based on this data. The sheets themselves are a mix of XML and HTML as per some article I can't seem to locate any more on Technet...

Most all of the computers that use the Intranet are using IE6 (no comments on this please, not in my control), and we have a mix of Office 2000 and Office 2003 (again, not in my control).

All the Office 2000 computers and only a handful of Office 2003 computers will open the sheets in Excel (the expected behaviour), but some of the Office 2003 computers will open the sheets in the IE window - and its confusing the hell out of the less-than-technical users that have run into this.

For the life of me I have been unable to reproduce the settings, or find what checkbox I need to check/clear to stop those few computers from opening Office documents in the browser. Does anyone know where this is?

Alternately, is there something I can do on the server end to force the client to open in Excel?

Lastly, we are looking at deploying Office 2007 some time in the near future - am I going to have to go through this again?

share|improve this question
up vote 2 down vote accepted

2 questions:

  1. Do the files all have the .xls extension
  2. Are they opening in Excel within the IE window, or opening as HTML/XML?

If they're opening in Excel within IE and have .xls extensions, there's this:

  • In Windows Explorer (not IE), go to Folder Options
  • On the File Types tab go to the XLS entry and click the Advanced button
  • Uncheck the Browse in same window checkbox

This is true for all Office 2003 formats.

If that is what fixes it, then there is nothing you can do on the server end. It's a client config. If not, you could try hard-coding a mime-type in your web server for .xls using application/

share|improve this answer
They all do have a .xls extension, and they are opening in Excel within the IE window. Kinda like Adobe Reader does with a pdf. – AnonJr Sep 25 '09 at 2:44
Did you try the suggestions I gave? – squillman Sep 25 '09 at 4:02
I'm trying to track down one of the problem computers. I tried setting up a similar VM but for the life of me I can't reliably reproduce the problem... – AnonJr Sep 25 '09 at 13:19
Ah, that sucks. Maddening, that. – squillman Sep 25 '09 at 13:34
That checkbox was checked on the computer I checked with this issue. Now to find a way to fix it with out having to walk a less-than-technical person through it... – AnonJr Sep 25 '09 at 17:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.