Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The file is a 40MB powerpoint file.

On my old server (RHEL 4, Apache 2.0, dedicated server), the file downloads without issue.

On my new server (Fedora 8, Apache 2.2, virtual server), I cannot get a complete download of the file using Firefox or IE. wget is able to get a complete download (after making one or more 206 Partial Content requests).

Comparing the httpd.conf files from both servers, the only significant difference was that KeepAlive was On for the old server. I changed KeepAlive to On for the new server, and that did not fix the issue.

I also tried turning off EnableSendfile and EnableMMAP on the new server, and that did not fix the issue.

What else should I try?

How can I determine if it is an apache issue, or caused by network issues with the new hosting company?

share|improve this question
    
Have you tried clearing your browser caches, and also any proxy cache in front of you? I had a similar problem once (incomplete download of a particular file) and it was just a local cache issue. –  Boden Sep 24 '09 at 22:17
    
Try to download the file using FTP and SCP, also check what are the download rate and the latency between the client and the server and compare this results with your two providers. This could help you determine if the problem is with apache. –  HD. Sep 24 '09 at 22:29
add comment

1 Answer 1

It turned out to be the load balancer. When I bypassed the load balancer, I was able to download the entire file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.