Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to connect to my office using sonic client and consistently failing. Actually sonicwall client informs me that connection to network is established, but when I tried to access one of the computers remotely using remote desktop it fails.

Here is a sonicwall log:

2009/09/24 12:54:58:109 Information	<local host>	Renewing IP address for the virtual interface (00-60-73-ED-F9-E6).
2009/09/24 12:54:58:187 Warning    	<local host>	Failed to renew the IP address for the virtual interface.
2009/09/24 12:55:03:359 Information	<local host>	The IP address for the virtual interface has changed to 192.168.0.xxx.
2009/09/24 12:55:03:421 Information	<local host>	The system ARP cache has been flushed.
2009/09/24 12:55:03:484 Information	{ipaddress}	NetWkstaUserGetInfo returned: user: user, logon domain: mymachine, logon server: mymachine
2009/09/24 12:55:05:750 Information	{ipaddress}		NetGetDCName failed: Could not find domain controller for this domain.
2009/09/24 12:55:05:750 Information	{ipaddress}		calling NetUserGetInfo: Server: \\mymachine, User: user, level: 3
2009/09/24 12:55:05:750 Information	{ipaddress}		NetUserGetInfo returned: home dir: , remote dir: , logon script:

I suspect that my router is not allowing connections, router I'm using is linksys WRT54G v8.2

Any help would be very much appreciated.

share|improve this question
    
Which version of the GVC are you using? I can connect with GVC 4.2.6.0305 to a TZ 180 across my home WRT54g. Also, I'm unsuer what you mean by version 8.2. I don't think you can mean firmware as mine is v1.02.5 build 002, Jan. 9, 2008. surely they can't jump 7 version numbers in nearly two years!? =) Also, has this VPN ever worked or is this a new problem? Also x2, can you ping the LAN IP address of the SonicWall? I.e., if it's 192.168.168.168 on the office LAN, try to ping that IP and see if you get a response. It coudl be as simply as not setting up interfaces right in the Sonicwall. –  Wesley Sep 25 '09 at 2:48
    
I'm not an network expert, so you will have to clarify GVC. By 8.2 I mean firmware version and this firmware version was released recently. This VPN was working normally until yesterday. The day before I've install some windows update. I'm on windows xp pro service pack 2. I'll try pinging "sonic wall server" and inform you –  krul Sep 25 '09 at 13:36
    
Oh sorry! GVC stands for SonicWall's "Global VPN Client". So I take it that your IT department is either non-existent or not very helpful? Really, they would be able to help you with this. Hopefully. =) You could also go into the Add/Remove programs control panel and select "Include Updates", then sort by the date column and uninstall the updates that were installed a few days ago to see if that helps. –  Wesley Sep 25 '09 at 15:48
    
Thank you for clarification and all the help. –  krul Sep 25 '09 at 20:17

2 Answers 2

up vote 1 down vote accepted

I have seen this same problem with Checkpoint's VPN. The issue is basically an overlapping IP scheme on your home network with that of your company. So if your office uses 192.168.1.1 in one of the networks and your home uses the same scheme then the problem surfaces. Try changing your home network to something else and see if that fixes it. An alternative is to check the settings of the VPN client, Checkpoint has an "office mode" that alleviates this problem.

share|improve this answer
    
My router uses 192.168.1.1 ip address. What might be the side effect of changing this ip on router? –  krul Sep 25 '09 at 13:39
    
You would need to reboot all machines on the network that have dynamic ip assignments (dhcp) so they get one with the new scheme and any static ips you would need to change manually. Other than that there should be no issues. –  EasyEcho Sep 25 '09 at 13:44
    
Also it only matters if 192.168.1.1 is also in use at your employer. Otherwise don't waste your time changing the IP. The issue could also be that Remote Desktop isn't allowed through the VPN tunnel, again checkpoint requires explicit rules for VPN users and so we have a rule to allow Remote Desktop from VPN to our internal network. –  EasyEcho Sep 25 '09 at 13:46
    
Thank you very much for your suggestions and explanations, I changed router ip and tried again but it didn't help. I will inform you guys once/if I resolve this issue. –  krul Sep 25 '09 at 20:15

Here is update on my connection problem. I tried to connect yesterday (in order to document connectivity issue) expecting error. On my surprise I was able to connect. I changed nothing on my router and on my computer since last failed attempt. I noticed that ip given was different from the one when I was failing to connect. That leads me to believe that the problem was indeed IP overlapping as EasyEcho pointed out. That is the reason I'm accepting his response as answer. Thanks again to everybody that tried to help me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.