Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a simple web service that I created that deploys perfectly on a default Glassfish V2.1 install on both a windows and a linux system. HOWEVER, In the production environment, Glassfish has the default port for the domain changed from port 8080 to port 80. Now when I try to deploy the web service it will not deploy to the server.

The production server is brand new and only was a few webpages on it. Other than the port everything else seems to be the same. I cannot change the port on the production server.

In fact I tried to change the port on the linux test server tfrom 8080 to port 80 and I get the same result as the production server.

Any ideas - other than don't use glassfish? :)

share|improve this question
    
Can you clarify "it will not deploy to the server"? Any errors in the logs? –  nickgrim May 31 '12 at 10:25

1 Answer 1

Are you running Glassfish as non-root user under Linux?

If so, use root to start Glassfish.

Non-root user can NOT listen on a port under 1024

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.