Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When accessing an Exchange 2003 server via IMAP, emails that were sent as text/plain (and ones that had no MIME encoding specified at all) get automatically converted to multipart/alternative with the original text/plain body and a text/html body. This is … stupid. It doesn't even bother to specify a monospaced font.

The new MIME part starts like this:

Content-Type: text/html;
    charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Diso-8859-1">
<META NAME=3D"Generator" CONTENT=3D"MS Exchange Server version =
6.5.7654.12">
<TITLE>{{subject}}</TITLE>

</HEAD>
<BODY>
<!-- Converted from text/plain format -->
<BR>

<P><FONT SIZE=3D2>{{body}}

(All the "3D" stuff is quoted-printable encoding for an equals sign; there's nothing wrong on that front, surprisingly.)

How can I make this stop?

share|improve this question

2 Answers 2

Gavin McTaggart responded to a similar question, albeit about Exchange 2007:

Have a look at this Technet document, specifically the ImapMessagesRetrievalMimeFormat switch. The documentation is exceedingly vague, but Exchange can force the format of the messages as they are retrieved from the server, either by user (as the link indicates) or on the service itself; in which case you would use the Set-ImapSettings command, and change the MessageRetrievalMimeFormat option.

I haven't had a chance to test it yet. I don't really have any notion that the Exchange Management Shell indirectly referenced exists or will function with Exchange 2003, though.

share|improve this answer

Isn't this configured on the Message Format tab of the IMAP4 Virtual Server properties pages? I believe that sending the message in both Text and HTML formats is the default setting.

share|improve this answer
    
I've played with that and it doesn't seem to actually have any effect at all. If you can refute that, please let me know. –  wfaulk Apr 1 '10 at 23:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.