Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In my quest to configure my shell to work exactly how I want it with respect to the alt/meta key I am having some trouble. Recently I added "bindkey -m" to my .zshrc and now whenever I start a zsh shell (ie open a terminal window) I get this error "warning: `bindkey -m' disables multibyte support".

Now since I don't care much about multibyte support atm, is there a way I can disable just this warning? Even better would be a way to use 8th-bit meta as well as multibyte. Also note that this happens on a clean zsh install on 4.3.9 and 4.3.10

My reasoning for wanting bindkey -m

vim: alt mappings (my own personal commands/mappings) zsh: alt mappings (such as Alt-. to recall the last argument of the previous command) emacs: alt mappings (lots of built-ins) So, is there any way to disable this warning or otherwise accomplish what I'm trying to do?

share|improve this question
    
See my answer here: stackoverflow.com/questions/1483158/… –  Dennis Williamson Sep 27 '09 at 11:14
    
Thanks Dennis, I accepted your other answer. I only posted it here because someone added the belongs-on-serverfault tag. –  Jason Axelson Sep 27 '09 at 12:30
add comment

1 Answer

up vote 0 down vote accepted

Using Dennis' answer from StackOverflow:

http://stackoverflow.com/questions/1483158/enable-zsh-using-8th-bit-as-meta-without-warning/1483354#1483354

You can sweep the message under the rug:

bindkey -m 2>/dev/null

Don't mappings to escape ([) also work for Alt for you? Alt-. works for me, for example, by default.

Also, unless you're talking about the command line editing modes, vim and emacs handle their own keyboard mapping. Settings in zsh won't affect them.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.