Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to execute a stored procedure on a linked MSDE 8.x server by running the following SQL against the parent SQL Server 2000 instance...

DECLARE @RC int

EXECUTE @RC = [LINKED_SERVER_NAME].[LINKED_SERVER_DATABASE].[dbo].[STORED_PROCEDURE_NAME]

GO

...but I get this error message:

Msg 7411, Level 16, State 1, Line 2
Server 'LINKED_SERVER_NAME' is not configured for RPC.
share|improve this question
    
what versions of sql server are you connecting to? –  Nick Kavadias Sep 28 '09 at 13:59
    
SQL 2000. (re-wrote the question to better explain the problem) –  Tim Lara Sep 29 '09 at 2:41
    
what do you mean when you say you can't see the stored procs? you mean in management studio? please provide an example of the call your making to an msde db sproc & the response/error, so as I might have a chance in figuring out whats going on –  Nick Kavadias Oct 6 '09 at 16:30
add comment

2 Answers

You can store credentials in a powershell session using get-credentials but I'm guessing that's not what you're after.

Powershell runs in the context of whoever startet it (like all windows executeables), so for SQL Server operations I'd just use integrated windows security for the connection, and then assign the correct SQL Permissions to the user/service account that you set up to be running the scripts. That way you use the security model in WIndows and won't have to make your own :-)

share|improve this answer
add comment
up vote 1 down vote accepted

In SQL Server Management Studio:

  1. Right-click the MSDE linked server instance and choose [Properties]
  2. Select [Server Options]
  3. Make sure that the [RPC] and [RPC Out] properties are set to [TRUE]

(in my case they were both set to FALSE)

share|improve this answer
    
Yes, this is correct. It's not a permissions issue, it's a case of RPC not being enabled. –  squillman Oct 15 '09 at 1:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.