Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I thought I had this figured out.

I built a php.cgi, but rather than have a copy of php.cgi in the /cgi-bin/ dir for each domain I have. I create a sym link to a common directory so they could all use the same php.cgi ref. Only problem is they are now also using the same PHP.INI file =/ I don't know how to fix this problem.

When I ran phpinfo on each domain, it referred to the first domain's PHP.INI file

any thoughts?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Per domain, try to add this command to vhost config or root .htaccess file:

PHPIniDir <Path to folder containing php.ini file>

Edit: PHP doc indicates it's a Windows-only command but I used it on Redhat/Debian boxes without any problem.

share|improve this answer
    
Thanks Ill give it a try. If it works I'll mark your response here =] –  qodeninja Sep 28 '09 at 16:30
    
Nope that didnt work. I got a server error. –  qodeninja Oct 1 '09 at 7:46
    
Which error do you get in Apache logs? –  Pierre-Yves Oct 5 '09 at 12:41
    
Not sure where to set this becuz under the root there are many different domains being hosted. –  qodeninja Oct 6 '09 at 6:11
    
This wont work. Passing options in the vhost or using .htaccess required mod_php to be used. In order to use this you would need to have an instance of the binary for each user and set a relative path for the per user configuration at compile time. –  Keiran Holloway Nov 20 '09 at 23:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.