Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I recently moved my app to a new server - the app is written in c# against the 3.5 framework. The hardware is faster but the OS is the same (Win Server 2003). No new software is running. On the prior hardware the app would run for months with no problems. Now, in this new install, I get the following error after about 3 days, and the only way to fix it is to reboot:

A network-related or instance-specific error occurred while establishing 
a connection to SQL Server. The server was not found or was not accessible. 
Verify that the instance name is correct and that SQL Server is configured 
to allow remote connections. (provider: TCP Provider, error: 0 - An operation 
on a socket could not be performed because the system lacked sufficient buffer 
space or because a queue was full.)

I have yet to find a service I can even shut down to make it work.

Anyone had this before and know a solution?

share|improve this question
    
Is this a 32-bit or 64-bit install of Server 2003? How much RAM is in the server and how much is SQL Server using? –  Sim Nov 1 '09 at 12:02
    
When you say 'moved to a new server', how was this done? Image, clean install, restore? –  CodeByMoonlight Nov 24 '09 at 19:34
    
I've just struck this on Server 2008 (x64) and SQL Server 2008 R2. I can't make connections from the server back to another SQL Server - it has dozens of open connections on that port to that server already. –  Matt Hamilton Nov 28 '11 at 1:17

3 Answers 3

up vote 2 down vote accepted

the only time I came across something similar was when some application openend a new connection to the db for every request - and never closed the old ones.

With more than 3500 concurrent, but idle connections the problems started (was SQL 2000).

I would check each day the number of current connections with the admin console to see if you reach unusual numbers.

share|improve this answer
    
I have also seen it in that case; however, as this application would run previously for months on end without problem, I am leaning towards discounting that possibility here. –  user2125551 Sep 28 '09 at 13:09

/3GB switch enabled in the boot.ini? (clicky)

share|improve this answer
    
I've seen this thread too - I have no /3g switch in my boot.ini on the IIS box. I wonder... does the error happen because the switch is on the DB server or the IIS server? –  user2125551 Sep 28 '09 at 13:03

You can try to edit the registry key by following the steps here http://support.microsoft.com/kb/196271.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.