Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to enable the Network Discovery feature on a newly installed Windows Server 2008 R2 instance.

The network connection is in the Home or Work profile (it is not domain joined). These are the steps I've followed:

  • Within the Network and Sharing Center I select Change advanced sharing settings
  • Then I select the Turn on network discovery option for the current network profile (Home or Work)
  • I then click Save changes

If I then go back to the Advanced sharing settings screen the Turn off network discovery option is selected and the machine is not visible to others within the Network node in Windows Explorer.

Things I've checked:

  • I can ping the server and connect to it using the machine name/IP address.
  • The Windows Firewall has exceptions for Network Discovery for both Private and Public networks.
  • File and Printer sharing is enabled and I can transfer files to/from the server by connecting to the server using a UNC path.

What am I missing here?

share|improve this question
    
I was under the impression that Network Discovery dealt with uPnP devices, not other computers. –  Powerlord Sep 28 '09 at 15:24
    
No, in W2K8, Vista, and Win7 Network Discovery refers to making your computer discoverable on the network. –  joeqwerty Sep 28 '09 at 20:48
    
Actually Network Discovery is for both computer and device discovery. From Windows help "[it] affects whether your computer can find other computers and devices on the network and whether other computers on the network can find your computer" –  dariom Sep 29 '09 at 7:20
    
Windows help is very underrated, but you just made it a little less needed thanks to this post. :) Thanks for doing the homework! –  Matias Nino Nov 24 '09 at 6:25

5 Answers 5

up vote 11 down vote accepted

I think I found the solution. From the "What is network discovery?" Windows help topic:

"Network discovery requires that the DNS Client, Function Discovery Resource Publication, SSDP Discovery, and UPnP Device Host"

I opened the Services MMC snap-in and saw that the following services were disabled:

  • Function Discovery Resource Publication
  • SSDP Discovery
  • UPnP Device Host

Enabling and starting these services did the trick and now Network Discovery is enabled and I can see the server. It doesn't explain why toggling this in the UI didn't enable these services.

Should have checked the Windows help first :-)

share|improve this answer
    
i read elsewhere that the services don't even have to be running; just not Disabled. i cannot confirm; but would love if someone else could. i'm trying to solve the same problem in Windows Server 2012 Standard; but it doesn't even have a SSDP Discovery service anymore. –  Ian Boyd Apr 8 '13 at 1:16

I had the same issue, I started only Function Discovery Resource Publication and it works.

Rafael.

share|improve this answer
    
Prefect! This works! –  SgtOJ Oct 29 '12 at 0:46

I find the Network and Sharing Center interface to be somewhat confusing and not very intuitive. What you can try is to share a folder (from Windows Explorer rather than the Network and Sharing Center or Computer Management consoles) so that Windows can enable the appropriate settings to turn on sharing and network discovery rather than you trying to figure it out in the Network and Sharing Center.

share|improve this answer
    
Thanks for the response. I think I've found the solution though: some services used by Network Discovery were not running (and were disabled). I've added an answer. –  dariom Sep 29 '09 at 7:06

I found out I need also to set the computer browser service to start automatically.

share|improve this answer

Thanks for that! However, I had to enable 'server' and 'workstation' in addition, to be able to finally discover servers on the same network.

share|improve this answer

protected by Jeff Atwood Jun 8 '10 at 5:51

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.