Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We restarted our Windows 2003 server R2 last night (09/27) and since that day we can not connect through RDP.

We have this kind of error using mRemote:

RDP Disconnected! Error Code: 2308 Error Description: Socket closed

Using Remote Desktop Connection we have :

This computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator.

Does anybody knows How to bound TCP to only one NIC ? could you please give me the path or command? Is there any command line I could use to do it?

Thank you for your help

Sabine (Houston,TX)

share|improve this question
    
A solution to the same issue is proposed here: serverfault.com/questions/49428/… –  Veynom Oct 19 '11 at 9:09

6 Answers 6

I've seen this plenty of times on 2003 servers, for some reason after a reboot the RDP service is not responding correctly even though it's running and another reboot will solve it... not the kind of solution one would want to hear though ^^

share|improve this answer

I've faced a similar issue, error 2308.

How I fixed it:

  1. I've opened services.msc on my machine.
  2. Connected via RPC to the server with non-working RDP.
  3. Restarted service "Terminal Service" and dependent service "Terminal Service UserMode Port Redirector".
  4. Connected to RDP successfully.
share|improve this answer

I'm not sure if I understand your question, but to only use TCP/IP on one NIC you would uncheck "Internet Protocol (TCP/IP)" in the network settings for any other NIC other than the one you want to have connected.

Not sure how that answers your RDP question - but as far as RDP goes you should check the server log. Either Terminal Services (RDP) server is down, there could be a firewall issue, or there could be a licensing issue that would cause that error.

share|improve this answer
    
Thanks Dave. Do I need to restart the server after the modification? –  sabine walker-deemin Sep 28 '09 at 19:17

Are you sure that the server was actually restarted? Maybe it the shutdown process hanged for some reason. Have you looked at the event log and seen the startup events?

share|improve this answer
1  
the server was restarted. My colleague came earlier this morning and restarted again the DC server. Now it works. The server displays on the screen and RDP connection works. We look at the events log but nothing relevant has been saved. weird hein! We contacted Dell support and they shipped us a new Motherboard in case the server goes bad again. Thanks for your help and analysis guys. –  sabine walker-deemin Sep 30 '09 at 13:56

You should check the log or use application like Wireshark to check why it happened.

share|improve this answer

Also had this Issue. Fixed it by activating "Keep-Alive-Connection". Follow this KB: http://support.microsoft.com/kb/216783

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.