Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have enabled the iis components for the first time on this machine, from control panel->add software->windows components, and rebooted.

When I attempt to start the "Default Web Site" (which shows as 'Default Web Site (Stopped)' ) from inetmgr nothing happens.. no errors, nothing in the event log. Regmon and Filemon show no obvious errors.

I've confirmed that nothing is running on port 80 and have tried changing the local port (8080, 8081 etc.,) with no effect.

Further info --

I have removed the install, rebooted, added it back in, rebooted ... still not working.

I have visual studio 2008, SQLServer 2008 installed.

share|improve this question
    
What is the status beside Default Web Site (stopped) in IIS MMC. –  Vivek Kumbhar Apr 8 '10 at 19:14
add comment

2 Answers 2

Is there another service listening on port 80? You can find out by running netstat from a command prompt.

share|improve this answer
    
as i say.. i checked that nothing is running on port 80 –  headsling Sep 28 '09 at 22:35
add comment

Does the site show as started in IIS Manager or the site just doesn't load? Did IIS ever work on that box? What other applications do you have installed on that server?

Make sure to check both System and Application log in Event Viewer and I would suggest trying Process Monitor (www.sysinternals.com) to see if there are any file or registry failures. Search for 'denied' after getting a capture. To get a capture, turn on Process monitor then do an iisreset and try starting the site. That should repro and capture any failures.

share|improve this answer
    
checked regmon and file mon ... no clear errors when iisrestart'ing i.e. no denied, but NOT FOUNDS are there.. not clear which of these would be an issue as they are common place in reg access. This is the first time i'm turning on iis on this machine and inetmgr shows the site as 'Default Web Site (Stopped)' . will update the question with details to your other question. cheers –  headsling Sep 29 '09 at 10:54
1  
Tis an odd one. It really seems like something else is fighting with port 80 although I know that you've said that you've tried that. Just for kicks, try starting it on another port (i.e. 81), and make sure there isn't a SSL binding yet. It should just have 1 simple binding. (mind you, if there was a port conflict, it should give you an obvious warning about that). The 'Not Founds' are likely ok. There are often lots of those. –  Scott Forsyth - MVP Sep 29 '09 at 13:58
    
tried changing the local port with no effect.. –  headsling Sep 29 '09 at 18:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.