Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've set up a VPN connection to my work network on my home PC - running Windows 7

It connects fine.

Once connected, I can ping machines that are on my work network using my home pc, however, if I try to RDP to them, it doesn't connect...

It seems to initially connect, It asks me for the logon user / password, and when I set them, and click OK, it gets stuck on a screen saying:

"Securing Remote Connection"

Eventually it pops up saying

"This computer can't connect to the remote computer.

Try connecting again. If the problem persists, contact the owner of the remote computer or your network administrator"

I know this computer is configured to allow remote connections etc... (and I've tried it with several different machines on the remote network)

Any ideas what i've set wrong?

share|improve this question
    
Give us more details on the VPN connection... –  xeon Sep 28 '09 at 19:31
    
Turn off the remote and local PC firewalls to see if the problem persists. If it goes away, we've narrowed it down and can start looking at firewall rules. –  Wesley Sep 28 '09 at 19:39
    
what details about the VPN connection would you need? –  alex Sep 28 '09 at 22:44
    
Need details on what kinda of VPN connection? Cisco VPN...? Sounds like a firewall issue to me... –  xeon Sep 29 '09 at 16:49

3 Answers 3

up vote 1 down vote accepted

On the Win 7 machine, start Remote Desktop Connection. Click on Options and go to the Advanced tab. For Server Authentication, do you have "Do not connect"? If so, knock it back to "Warn me" and try again.

share|improve this answer

Validate that you can communicate with the remote IP over TCP 3389. You can validate this via telnet:

telnet [remoteServerIP] 3389

If you get a connection refused look at any local firewall software then validate ACL's on both networks.

share|improve this answer

I assume you've been using a standard ping. Try a ping with a larget packet size.

ping -l 1500 server.ip

If this fails and the standard ping works you have an MTU issue at some point. Keep lowering the number after -l until your pings transit properly. We'll need to know the details of your VPN concentrator to give instructions on how to fix that. It can be set at the remote endpoint and firewall.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.