Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We've got several Supermicro servers that we're trying to upgrade the RAM on so that we can run virtual servers on them, but only a few of them took the RAM upgrade that we performed. We double-checked to make sure that the RAM was all in the proper slots and that the RAM itself wasn't bad. We also flashed the bios to the most recent version to make sure that wasn't the problem, but to no avail. A large number of our servers just won't see more than 4GB of RAM. The ones that do don't have any apparent differences to the ones that don't, so we're completely stumped.

Any ideas or suggestions anyone can give will be extremely helpful.

share|improve this question
    
They can't see the RAM in the BIOS or the operating system? Which OS? –  Mark Henderson Sep 28 '09 at 21:46
    
Either. The RAM doesn't show up in the BIOS and uname -a says: Linux xen008-sit 2.6.18-128.1.6.el5.xs5.5.0.496.1012xen #1 SMP Fri May 29 07:35:00 EDT 2009 i686 i686 i386 GNU/Linux –  Jeremy Privett Sep 28 '09 at 21:55
    
What kind of troubleshooting have you already done? Tried swapping the FBDIMMs to other servers to see if the problem follows the RAM or the motherboard? –  Mark Henderson Sep 28 '09 at 22:51
    
We've verified that all of the individual RAM sticks work. Have tried swapping between the 4GB servers but we haven't tried in and out of the working 8GB servers. We'll give that a shot. Any other thoughts? –  Jeremy Privett Sep 28 '09 at 23:34

2 Answers 2

up vote 1 down vote accepted

Have you tried setting the BIOS 4GB PCI Hole Granularity to 1GB? Also make sure you are using pairs in channels 1A-2A, 1B-2B and so on.

When I say 1A-2A that means slots 1 and 4. This board has the slots going in order: 1A, 1B, 1C, 2A, 2B, 2C. If you use 2 sticks you can use either 1A-2A or 1A-1B configuration. When using 3 sticks: 1A, 1B, 1C. When 4 or 6 you must pair up the memory banks: 1A-2A, 1B-2B, 1C-2C

share|improve this answer

You're running a 32bit OS, so I believe you'll need to install the specific PAE kernel, or install a 64bit version of your OS to enable the OS to address more than 4Gb of RAM:

yum install kernel-PAE

I would advise 64bit OS rather than 32Bit+PAE as it handles >4GB of memory far better, but if you can't do a re-install PAE should at least enable you to use the RAM.

share|improve this answer
    
Sorry, the OS isn't the problem. Three of the servers running the exact same OS see the RAM just fine. –  Jeremy Privett Sep 28 '09 at 23:31
1  
A negative score for my answer? Seriously? The original question, nor the replies, never indicated that all the boxes were running identical OSs or at the least that there were ones using the one kernel mentioned successfully using more than 4GB of RAM. Given the need for PAE on a 32bit Kernel to access >4GB of RAM, and no public release notes for the XenSource kernel to suggest it runs PAE whilst not adhering to the RHES naming scheme.. was it really a 'negatively bad' suggestion? Users can only help if the full picture is known. Otherwise we evidently waste our time and lose rep. –  Twirrim Sep 29 '09 at 3:11
    
+1 for you. It wasn't a bad question. –  osij2is Oct 1 '09 at 15:48
    
By the time you posted your answer he had already commented that the RAM does not show up in the BIOS. Last I checked, the BIOS is not connected to the kernel in your OS. –  Mark Henderson Oct 1 '09 at 21:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.