Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got Database Mail set up successfully, I can send test emails, however when I go to set up an alert to be sent by email to an operator I don't have a checkbox to check to say email should be sent.

I've checked the following:

  • SQL Agent Alert System has Email set up

  • I've restart SQL Agent

  • I have a default mail profile

  • The profile is a public profile

  • Operators are set up (that's where I can't see the email checkbox)

  • SQL Server & Agent are running under the same account the SQLMail is set up for

I'm using SQL Server 2005 SP3, if anybody has any thoughts it would be much appreciated.

share|improve this question
    
Are the SQL server services running under the same account that the mail profile belongs to? Also, do you have operators set up? Silly question, I know, but you didn't mention it explicitly so I thought I'd ask. –  RainyRat Sep 29 '09 at 11:06
    
Updated the question, thanks. –  MrEdmundo Sep 29 '09 at 11:10

1 Answer 1

up vote 1 down vote accepted

From SSMS, click on the plus next to Management. From there, right-click on Database Mail, and Configure Database Mail....click Next on the Welcome Screen. Select Manage profile security and click Next. Are there any profiles listed here? Are any of them set to use the default profile? If not, set it to yes and try again.

A good resource for stepping through and setting database email up can be found here.

Edited to add

Based on your comments below you should patch SSMS in addition to SQL Server.

share|improve this answer
    
I have this option enabled in Database Mail but not SQL Mail. I assume I only need it in Database Mail as SQL Mail is deprecated and Alerts aren't? –  MrEdmundo Sep 29 '09 at 14:14
    
I just checked out the link. When I open up profile security I don't have a checkbox to say whether a profile is public or not.... –  MrEdmundo Sep 29 '09 at 14:53
    
Rather than trying to troubleshoot what you have and haven't done, I would recommend stepping through my link and setting them up again. –  GregD Sep 29 '09 at 15:19
    
Tried that, twice, to make sure I didn't miss anything first time. –  MrEdmundo Sep 29 '09 at 15:23
1  
Is your install on SP2 by chance? There are some fixes regarding Alerts: support.microsoft.com/kb/921896 –  GregD Sep 29 '09 at 15:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.