Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

the thing is that I just installed IIS in my Windows 7 computer to test it out, but I'm getting this error as soon as I try to load the localhost on my web browser:

Service Unavailable


HTTP Error 503. The service is unavailable.

I found this solution but it didn't work. Anyone has an idea of what's going on?

Thanks!

More Info:

I checked on the Application Pools, as soon as I go to http://localhost/ it stops the application pool of thw website I try.

share|improve this question
2  
What's the error in the application log? –  mrdenny Sep 30 '09 at 4:24
    
How can I see this? I thought in the event viewer but seems like no... –  Carlo Sep 30 '09 at 5:18
    
I think this is what you asked: The worker process for application pool 'DefaultAppPool' encountered an error 'Cannot read configuration file due to insufficient permissions ' trying to read configuration data from file '\\?\C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG\machine.config', line number '0'. The data field contains the error code. –  Carlo Sep 30 '09 at 5:48
add comment

3 Answers

up vote 3 down vote accepted

Fixed it!

mrdenny thanks for pointing the log out. With that I was able to search on google in a more specific way. My problem was this:

"The worker process for application pool 'DefaultAppPool' encountered an error 'Cannot read configuration file due to insufficient permissions ' trying to read global module configuration data from file '\?\C:\Windows\Microsoft.NET\Framework64\v2.0.50727\config\machine.config', line number '0'. Worker process startup aborted."

Solution:

To fix this issue, give the ISS_IUSRS account explicit read rights on the 'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\config\machine.config' file, do a iisreset and you should be fine.

Source

share|improve this answer
add comment

I was having the same problem and the previous answer did not solve.

This following solved it:
Give permission to C:\Windows\System32\inetsrv\config folder to Network Service user.

share|improve this answer
add comment

Thanks, I was having the same problem with the 'Cannot read configuration file due to insufficient permissions' error. I tried your solution, but you have a typo. Its IIS_IUSRS not ISS_IUSRS.

Regardless, I use another approach, which is to run the IIS Server as yourself instead of IIS_IUSRS. This is not as secure, but here's how to do it anyway: 1. highlight your Default Web Site, or virtual directory 2. Click on Basic Settings in Actions pane 3. Click "Connect As" button 4. Choose "specific user", then click set and type in your user name and password

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.