Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I install SQL SERVER 2005 on my Windows 7 machine. Now, when connecting to the server there is nothing being displayed in the Server Name. Am I missing something?

Same happens with SQL SERVER 2000!

share|improve this question

migrated from Sep 30 '09 at 7:04

This question came from our site for professional and enthusiast programmers.

Personally, before I listen to any other replies on this I would apply the latest service pack to the SQL 2005 immediately. Most likely the service pack will fix the problem.

share|improve this answer
SP3 is mandatory for SQL 2005 on Windows Vista or Windows 7. It even states it in a huge popup (that nobody reads) before it will even let you install it – Mark Henderson Mar 11 '10 at 3:07

You mean that if you do the following, it returns NULL?


You can use this to set the server name:

sp_addserver <new_name>, 'local'

I think you will need to restart the MSSQL service.

share|improve this answer
I click on Management studio and then the login box appears. I choose Windows Authentication and the server name is blank. The username appears as DOMAIN/JOHNDOE. Where DOMAIN is my computer name and JOHNDOE is my username. I restarted the service but still the same! – user21004 Sep 30 '09 at 3:13
You're supposed to fill in the blank with the name of the server you're connecting to. Try 'localhost', or just a simple dot '.' – Remus Rusanu Sep 30 '09 at 3:19
I tried it and it said login did not work which is strange because I am using Windows Authentication. – user21004 Sep 30 '09 at 3:28

You'll most likely want to use "(local)" to connect to your local instance. Is it named? If so, you need to specify that too:


Make sure the SQL service is running..

share|improve this answer
SQL SERVER is running. And it shows the server as MYMACHINE-PC which is my machine name. If I try to stop the server then it throws the exception "Access is denied". – user21004 Oct 1 '09 at 1:31

Sounds like the Windows account you're using doesn't have permissions to access the database instance (are you an administrator?). Try logging in using SQL authentication as sa and then adding your Windows account to Logins (Security > Logins).

share|improve this answer
you would have to enable the "sa" account first. by default, the account is disabled. – djangofan Dec 3 '09 at 1:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.