Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've recently taken control of a server with Plesk 9.2.2 installed. There are no domains registered yet, but i've "created" a domain within Plesk and successfully uploaded my Drupal site via FTP and PHPMYADMIN.

However, I've got problems. I can't give you the proper urls or paths for commercial reasons, but the site is available for preview at a location like this:

https://abc-v12np.pl.myhosting.co.uk:8000/sitepreview/http/myproductionsite.co.uk/

I made sure I edited the SQL to change any paths from my staging server to the paths on the new server, but Drupal is completely unable to log in - it breaks out of the preview area on the login redirect to something like this:

https://abc-v12np.pl.myhosting.co.uk:8000/?q=user/login

1) Is there any way of making apache or drupal more bulletproof when using plesk domains like this? Is there something I forgot to set up? 2) Is there another way of accessing my site? Could I do something like http://ip-of-my-server/index.php

I've edited all the drupal files i can think of - adding $base_url in the sites/default/settings.php and even editing the SQL on the database to have full server paths, but it's not really fixed the problem.

All help REALLY appreciated :)

share

migration rejected from stackoverflow.com Jan 14 at 4:19

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as off-topic by HopelessN00b Jan 14 at 4:19

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
This question appears to be off-topic because it is about working with a service provider's management interface, such as cPanel. –  HopelessN00b Jan 14 at 4:19

3 Answers 3

In your drupal .htaccess file make sure you set your RewriteBase:

RewriteBase /sitepreview/http/myproductionsite.co.uk
share
    
Hiya, i've just added that, but it's not made the difference I'm afraid. –  MrFidge Sep 30 '09 at 19:00

OK htaccess has: /sitepreview/http/mysite.co.uk

And the Drupal settings.php has: $base_url = '/sitepreview/http/mysite.co.uk'; // NO trailing slash!

But no joy, I think it's something to do with Apache or Plesk itself?

share
up vote 0 down vote accepted

The answer was that Plesk does not support this in any way.

You either have to edit your hosts file to spoof it, or you can simply point any spare domain you have at the right IP address and then password it all.

share

Not the answer you're looking for? Browse other questions tagged or ask your own question.