Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to setup a Hurricane Electric (tunnelbroker.net) tunnel from a Solaris server. Looks like everything is working fine, except that no traffic actually seems to transit our router. Router needs to pass IP Protocol 41 traffic, but I don't know if it does or not. Poking around on the Netgear site has done nothing to answer my question. Anyone know, or have good ways to test (or ways around it?)?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Unless it's explicitly blocked by a firewall rule, the router should pass the traffic -- an IP packet is an IP packet, whatever the contents. (Protocol 41 is IPv6 encapsulated within IPv4). The router itself doesn't need to know anything about IPv6.

Now, if you're using NAT, that will be a problem -- most NAT implementations won't automatically forward protocol 41 packets, and it can be tricky to configure manual forwarding for anything other than TCP or UDP. Additionally, it advertises itself as a 'VPN router'; if your traffic is going over a VPN, it's conceivable that firewall or forwarding rules at one end or the other may be dropping protocol 41 traffic.

To troubleshoot, I'd try simplifying the configuration as much as possible, then adding complexity back in. Start with the box configured as a simple router -- no VPN, no NAT, no firewall rules, and see if it works. Then add the rest of your configuration back in bit by bit, and see what breaks it. Once you know that, it should either suggest a solution, or give you enough information to ask a question with a less vague response *grin*.

share|improve this answer
    
+1 for the troubleshooting tips. –  Raffael Luthiger Sep 30 '09 at 23:57
    
Unfortunately, it supports a production environment too, so changes I can make to the router are quite limited. Talked to another local Netgear/IPv6 user and he said he had to drop the firewall completely to get IP 41 to pass. Temporarily got a single machine running off of freenet6 there for testing (it tunnels over TCP). Looks like I'll probably have to try to bring up an AYIYA tunnel with SIXXS after all (was trying to avoid the AYIYA method since it's more complex) to get a fully routable subnet setup. –  Brian Knoblauch Oct 1 '09 at 12:21
add comment

The reference manual is here:

http://kbserver.netgear.com/pdf/FVS124G%5FRM%5F30Mar05.pdf

There is no indication of any IPv6 support.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.