Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

To recreate:

  1. Setup Server 2008 standard
  2. Install ColdFusion 8 Enterprise Multi instance
  3. Confirm that CF admin works by going to http://servername/CFIDE/administrator/index.cfm from another PC.
  4. Open IIS Manager on test server
  5. Highlight the Default Web Site and click Basic Settings on the right
  6. Change the "physical path" to something other than the default. In my case I'm doing E:\directory
  7. CF admin is no longer accessible

  8. If you change the "physical path" back to C:\inetpub\wwwroot CF admin is still not accessible

  9. If you reinstall CF8 it will restore the working configuration mentioned in step 3 above.

Note "physical path" is an IIS term for the logical mapping from a site name to a directory where the content is held. In steps 6 and 8 I am not moving any files on the hard drive I am only changing settings in IIS. Also worth noting that I didn't change any settings in CF Admin or anywhere else in Windows or on the network. This is purely caused by changing a single setting in IIS.

On my production server I'm using CF8 standard and the physical path of the Default Web Site is E:\directory\subdirectory and the CF admin still works so I'm surprised to see this fail.

A. I want to know how to fix it without uninstalling and reinstalling CF8

B. I want to know if there is a way to change this without breaking stuff every time I do.

One suggestion is to remove and recreate the wsconfig mappings. This seems like a valid thing to explore the options are:

Jrun Host: localhost
Jrun Server: admin or cfusion
Web Server: IIS
IIS Web Site: All or Default Web Site
Configure web server for ColdFusion 8 applications: checked or unchecked

Which choices for Jrun Server and Configure match the ones that the setup does? I don't know if they match the setup but I can confirm that choosing the ones in bold fixes the overall CFADMIN page. Now I have to figure out how to get to the instances admin pages and confirm that I can make other changes without breaking anything.

Note: restored multiple-instances tag. Coldfusion behaves much differently in single instance mode than in Multi Instance mode. Questions about Cold fusion need to be tagged to show the difference. If you believe there is a better way to tag it do so but only if you understand the differences in the types of Coldfusion installations.

share|improve this question
    
Note that just undoing step 6 and changing the physical path back from E:\directory back to C:\inetpub\wwwroot doesn't fix the CF Admin. At this point something has been changed. Also note that I haven't moved inetpub\wwwroot or the CFIDE folder. The path for the CFIDE folder should be valid but trying to modify the CFIDE virtual directory in IIS gets me "this virtual directory does not exist" and I can't remove or edit the virtual directory. –  pplrppl Oct 1 '09 at 13:14
    
Going through the create virtual directory process gets rid of the "this virtual directory does not exist" error but doesn't change the behavior of CF Admin. –  pplrppl Oct 1 '09 at 13:32
add comment

4 Answers

When you install ColdFusion it asks what folder your webroot is. In most cases this will be the same folder as the default web site in IIS. The installer puts the CFIDE folder into the default root, so when you go to that folder on the default web site, it loads up properly. When you change the folder of the default web site, however, the CFIDE folder is no longer in the folder specified and so you get a 404 error.

For any web site that needs to be able to get to the CF administrator, or needs to load the JavaScript validators for CFFORM among other things, you will need a CFIDE virtual folder mapping in IIS at the root level of each web site. You shouldn't need to reinstall ColdFusion or anything like that.

share|improve this answer
    
Yes, changing the folder makes the path a 404 but it shouldn't. The path to the virtual directory hadn't changed. Just the location of the HTML/CFM. Why does IIS 7 break the virtual directory when the path to the virtual directory hasn't changed? –  pplrppl Oct 1 '09 at 13:35
    
When you install ColdFusion, the CFIDE folder on the default web isn't setup as a virtual folder, so if you change the path of that web site entry, you need to create one for it. –  Justin Scott Oct 7 '09 at 2:21
add comment

Usually when something like this happens with ColdFusion its because the "cfide" directory is not pointing to the right place.

Take a close look at your virtual directory mappings and make sure its correct.

You didn't mention what directory you actually installed to so I'm going to guess C: drive. If that's the case then you need to change your virtual directory for cfide to point to E:

Good luck.

share|improve this answer
add comment

Are you saying that you changed the mapping to the site's file in the IIS administrator?

First things first: a 404 error would be served by IIS. ColdFusion shouldn't even be involved yet. Place an html file in the directory, and try calling it directly and see what happens.

Your other issue may be with JRun's web server connector. This is a bit of java that handles the bridge between CF and your web server (in this case IIS). in your Jrun4\bin folder is a wsconfig.exe. This opens a java app for managing the connections. Remove the existing connection, then add a new connection between your instance and the proper IIS config. Even if it reads the same as the last time, the 'move' you previously did in IIS may have hosed the connector, requiring it to be reset.

Just some suggestions. Hope you figure it out.

share|improve this answer
    
It serves html just fine. The question on wsconfig is: What is the default mapping? I'll edit the question to make the options clear. –  pplrppl Oct 9 '09 at 15:30
    
Those settings really depend on how you want it setup, but the default is cfusion (admin is for the jrun admin) attached to All Sites and Configure all for CF 8 apps should be checked. Now, if you setup additional instances you will probably have to adjust your connector, and you can setup more than one with this utility. –  Steve -Cutter- Blades Oct 13 '09 at 2:41
add comment

I've seen this and other problems when I use a default IIS connector during the install. My solution is to install with the built-in server, which in the multi-instance install will put CFIDE on port 8300 (if it's available).

Then I can monkey around with IIS to my hearts content and not bork up CF. It's made my life ever so much easier, especially when other people turn off the default site to get things like Sharepoint to work.

As for your issue, your virtual mappings may not be getting set back when you change the physical path. I've seen that in IIS too, only in IIS 6. I haven't tried it in IIS 7 yet (just got my new dev box last week).

share|improve this answer
    
Interesting answer. I always assumed installing the built in web server would change how coldfusion interacted with IIS. If you are saying there is no drawback I suppose I could experiment with that setup. –  pplrppl Nov 3 '09 at 19:58
    
I've never seen an issue. What it does is put all the CFIDE stuff under the JRun4 servers folder, outside of IIS. Then you use the Web Server Connector to attach a CF instance to all IIS sites, or, in my case, to a particular web site. I find it's cleaner to do it that way, so I can always get on a server and go to port 8300 to do instance management and other CF work. –  Milner Nov 4 '09 at 13:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.